Diagnostic application - works with CANBus/USB converter (diagnostic cable). Must have for all dealers and DIY VX-1 owners. It is Windows based application, works on XP, Vista, 7 and 8 (we didn't test it on 10 yet)

Before installation check what system you are running (32 or 64 bit) - here is explained how

For 32 bit system download this file - Vectrix Diagnostic for 32 bit Windows

For 64 bit system download this file - Vectrix Diagnostic for 64 bit Windows


Here basic manual of diagnostic - Vectrix Diagnostic Manual

This article was helpful for 22 people. Is this article helpful for you?

Hello ,in the vectrix diagnostic program What function does the tab "Start Bms Stimulus"?Thank you.

Hello,

thank you for your e-mail.


Is used during the programming of the bms, or to let the bms tranmitt data when disconnected from motor controller, is it a command equivalent to”START BMS DATA TRANSMISSION”

Not to be used from regular dealer.


Hope it makes sense,

Anna

Mine is 2.1bdoes not have a start bms stimulus

I have a different diag version, which do u recomend also diffrrent firmwares

There are few versions of diagnostic - one on portal is the latest released by Vectrix. For NiMH bikes there are older versions (before 2011) which have some functions specyfic for Ni system


Regards

Hello Piotr,

I think the software does not work on win 8 and 10.

Launching the application window appears with Vectrix logo, but nothing more.


What am I doing wrong??

Thanks.

Regards.

For me works fine with both Windows.

Will this software diagnose charger and fuse problems?

Dan

It may help to diagnose, and will be requaired to update firmware if you fix the hardware.

To run the diagnostics program, I must put the charger back in the bike first, then connect my CANBUS device to the bike and to my PC? The program will tell me what is wrong with the charger? I opened up the charger and did not see any fuses or see or smell anything that looked burned up or swollen. The bike stopped charging after the charging cord plug shorted out. I replaced the plug but nothing happens when i plug it in. I have been using a heavy gauge extension cord to charge the bike for over a year with no problems. Also, does the charger sense 115V or 240V and adapt to either voltage? I have a 240V adapter cable with a 115V socket on it that works to charge my 2016 Volt. If I get the Vectrix charging again, can I plug it in to the 240V circuit to charge faster? Thanks for all the help and support. It is very scary to own a Vectrix in the U.S. with the only support coming from you guys in another country!

DanDiego

Yes. To diagnose the issue with charger it has to be in the bike, diagnostic cable connected to bike and PC. Charger works on any voltage between 110-250AC.

If the problem happened after the AC cable was shorted - most probably you have damaged the AC filter module, if it's a gold Runke charger.(look here Charger Types - compatibility with Lithium Batteries SX-BC-CONV) you can fix it. If it is silver ESD charger - I'm afraid you will need new charger.

Regards

I have silver ESD charger. Does that charger include an onboard BMS? I work with some electrical engineers who think we could rig up an aftermarket charger for the batteries. They asked me for the Li-ion battery pack specs: volts, amps, KWH, etc. Thanks!

DanDiego

So the charger is gone. You need a new one. Vectrix charges does much more then charging - in fact it manage almost entire display of the bike (dashboard), handles the trouble codes, communicates with motor controller, ICM and BMS (in Li version) or Temp Sens (in NiMH) version. Regards

Does the bike need to be powered on to run the CANBUS cable and diagnostic programs? If I buy a new charger from you guys and plug it into the bike and it still does not charge, can I return the charger? How much is a new charger including shipping to San Diego, CA? Thanks!

Can the charger be repaired?

What is your return policy if I buy this replacement charger for my VX-1 Lithium+ and I install it and the bike does not charge? Do you want my current charger as an exchange? 

The two black wires on the 115V three-prong U.S. charging cord plug shorted out and burned out the plug. I replaced the plug and the bike no longer charges. I removed the charger, opened the case, no fuse or obvious shorts or burned components. My concern is that I don't know if it is the charger or some other electronic component on the bike, like a fuse somewhere else besides the charger. Also, my batteries have dropped to almost zero. 


Attachments:
image.png

Hello DanDiego, Perhaps that your problem is on the MC, and I think that you have burned one little fuse near the white plug the center fuse. For test you must unplug the battery connector, remove the MC board and unsoldering the fuse. For replug the battery you must use one bulb lampe if you don't want burned the fuse again.
IMAGE00207.jpg
You can use one car fuse like this:
http://visforvoltage.org/sites/default/files/u10255/MC%20board-2.jpg

Be careful with the power from the battery.

Thanks Armand. I don't quite understand about using one bulb lamp to replug the battery. So if the fuse is bad, I replace it, and then when I plug in the battery again, am I turning on the headlight, is that the bulb lamp you mean?

You must use the bulb lampe or special limiter plug before connect the battery if you don't want to blow the fuse again, like this:


Lampe Bulbe


Use a special gloves for working in your battery area and not like me.


Bests regards

Dan

Since you are located in US, where we don't have any dealer at the moment, you can try to contact David Dugas (ex EE Vectrix) - 508 212 7236. Although he lives on east coast, he may know somebody in south CA capable to work on VX-1 and with his help you diagnose the bike.


The blowed little fuse is one on the three black plastic, the center fuse.

DanDiego i can pobably help you can msg me at 9725339330

clipboard-image-marker

Hi...


If I buy this adapter cable to the scooter vx-2

(http://www.shop.vectrixparts.com/canbus-filters.html)

more diagnostic cable

http://www.shop.vectrixparts.com/pcan-usb-ipeh-21e.html

can do the speed upgrade from 28 to 40 mhp?

clipboard-image-marker




The firmware is included in the diagnostic cable?

Hi

Changing the speed setup is in most of the countries illegal.

But yes you can upload the 40mph firmware to the bike using the CAN cable.

Hi,


i try ran Vectrix diagnostic but the software doesn't run..


I have windows 10.

I install the peak can bus drivers and turn of the antivirus and firewall.


But nothing results..


Any suggestion?

Regards

That's correct. On most W10 diagnostic won't work (suprysingly it works on some english versions).

We use virtual machine and install Windows XP on it - there is a version which can run even on USB memory stick.

We are working already on new version of diagnostic.

Thanks Piotr,


I instal a virtual machine with win Xp 64bits, the aplications install with sucess, but the vectrix icon (to run the aplication) doesn t appear..

Type in the windows search bar vectrixdiagnostics - when you find location do right click, create shortcut and copy / paste it on the desktop

I have a problem which I need some help with. I had a problem with temp sensors, and decided to install the "no sensors" version of the charger firmware.


So I've just tried to re-flash the ESD charger in my VX-1 Nimh. I followed the detailed instructions to the letter, and all went well until I clicked the PROGRAM button to install the no temp sensor version of the Laird firmware into the charger. Then I got the message "Transfer Failed to VX1 Ni Vehicle Charger". As suggested I left the bike on, and restarted the laptop and ScooterDiag and retried. Same result. Ultimately had no choice but to shut things down.

Now when I turn on the bike all is fine, except solid red battery because its very low, and I get a GO, bike moves etc. However when I plug in and turn on the mains to charge I get no action at all from the charger. No fans, no lights, no dashboard indications. When I run scooterdiag both the charge and temperature panels are red, but otherwise no faults shown.

Anyone have any clue where I go from here?

Melvyn

What do you mean by "no sensors' firmware?

It looks for me like you have programmed the ESD charger with EVPS firmware.

I'll ask Matteo to assist you.


Regards