Reprogramming VX1 after lithium battery upgrade

Gary 1 year ago updated by Azzuro 1 year ago 12

I just swapped in 36s Chevy Volt batteries to a VX1. I am not yet using a BMS. The original nimh temperatures sensors were non-functional before the swap due to corrosion, so those temperature sensors have been removed. I am super excited that the scooter runs well; however:

  1. the original ESD charger only works for ~10-15 seconds then shuts off, likely due to the missing temperature sensors
  2. the wrench and temperature dash lights always flash, likely due to the missing temperature sensors

I would like to take a minimalist approach to get the ESD charger working and turn off the dash warning lights. I have the PCAN adapter, have successfully monitored the CAN bus, but have not attempted reprogramming any controllers yet. I have spent ~20-30 hours reading many forum posts to try doing this myself. Much of this information is from 8-10 years ago and there are frequent horror stories of bricking scooters due to something happening during controller reprogramming, which has me scared.

What are people's opinions on the Dugas versus The Laird's firmware files?  Can someone point me to the most recent version and procedure to reprogram my ESD charger to work with these 36s lithium batteries?

Hi there,

   All factory charger firmwares those are written for NiMH have the safety measure you are experiencing - without the CAN messages from the temperature sensors they terminate the charging. The Dugas firmware files (which are not official Vectrix) provide you a feasible option with ESD charger (not feasible for the newer Runke / Gold chargers). It is also highly recommended to disconnect the charger from the CAN bus when you perform the firmware upgrade on the Motor Controller, absolutely no disruption is tolerated during that step due to the limitations of the processor.

Needless to say you will still need a BMS to prevent the risk of cell level overcharge etc. however the Dugas firmware itself is willing to work without it.

Azzuro, thanks for the input.  X Vectrix posted a few months ago in https://visforvoltage.org/forum/14581-another-leaf-conversion-need-lairds-firmware a resource for the Dugas firmware.  Do you know if that is the latest/greatest Dugas firmware?

Thanks for the suggestion about disconnecting the charger before reprogramming the MC.  I assume just removing the charger's data line will accomplish this?  Bricking the MC is my biggest fear! 

To get my charger working with the Dugas' code, must I reprogram the charger (DE-ESDR09.hex), interface control module (DE-ICMR07.hex), and motor controller (DE-MCR08.hex)?  Does the order matter?  Is there a source for the original Vectrix firmware (charger (REV 3001), interface control module (REV 1008)), and motor controller (REV 1017)) in case I need to revert back?

Hi Gary. Correct, those Dugas files are actually newer than the ones I had, should be good. In terms of the order I would go with ICM then MC and finally reconnecting and programming the charger. Only the big data/low voltage connector needs to be removed from the charger indeed (the other two connectors are just for the power cable and the battery high voltage side). I have reprogrammed my MCs at least 10 times and never had an issue, you should be fine as well.

I have the original files you have mentioned, let me set up a share for you with those next week.

Azurro, Oh no!  I followed the steps above to reprogram controllers using VectrixDiagnosticsGUI.exe and Dugas firmware
1. Reprogrammed ICM … got "CAN BUS Fault" in the Status area and “Attempting to resume motor controller traffic” at bottom of screen.

2. Reprogram MC…"Download completed successfully" but still have CAN BUS Fault.

I'm really stressing out.  Hopefully you have some idea how to proceed?

OK, quick update.  (wipes forehead). After a bunch of stress and debugging, I switched to scooterdia.exe v21, and that worked much better!  Successfully reprogrammed ICM, MC, and Charger with Dugas firmware.  

I'm now trying to use VX1 Configurator R2.exe to reconfigure the charger limits.  It let me change the MC voltage limits and the number of battery cells, but it won't let me change the Max Cell Voltage (it's 0.000 volts right now).  I tried the comma versus dot thing mentioned https://visforvoltage.org/forum/14235-problem-dougas-engeneering-firmware, but that doesn't change anything.

What am I missing? 

Nice progress! Indeed the Vectrix diag app is the official diag from Vectrix itself and that is the way do upload the firmware images etc. On the other hand the VX1 Configurator app is just a Dugas frontend specifically written for finetuning the parameters only in the Dugas firmware.

My adventure with the Dugas firmware was fairly short because I have the newer chargers and the Dugas version made it acting weird. In case you leave the Max Cell Voltage showing zero does it prevent the bike from running and/or the charging starting ? If yes, there is a way to set these parameters using the handlebar controls (at least on the factory firmware), let me check the steps on my bike during the weekend.

Let me mention one more aspect regarding this value. The actual way how the Li-ion charger fws work is they are simply "blindly" charging the battery based on the sum HV voltage and start slowing down when the battery is not capable to receive more energy (starting current starts to drop) around 145 volts.

Obviously this is not a safe approach since there is always a chance some of the cells have already reached 4.2 volts while the rest are still on a lower level. This is where the BMS comes into the picture by sending the individual cell voltage values to the charger (a bit simplified explanation) allowing the charging process to wait for balancing etc. The Max Cell Voltage is there for this control mechanism, without a BMS present the changer may not use it at all.

The bike will currently run (I only tested moving forward/backward a few feet in my garage) and "start" to charge at like 1.5A for ~10 seconds and then stop charging.  

I assume Dugas' charger FW took "Number of cells" x "Max Cell Voltage" = "Pack Hi Voltage Limit".  Right now, b/c I can't modify Max Cell Voltage, that calculation for me is 36 x 0=0. During this, my odometer says "Low 000", "hi 000", "buSULT", which is what I assume is stopping charging. I'm hopeful that if I can figure out how to change Max Cell Voltage to ~4.000, it will actually charge.

Probably this newer version of the Dugas charger firmware is already designed to work with BMS. Do you have the earlier versions DE-ESD03, DE-ICMR06 and DE-MCR04 ? If not I can send them in an email. I would focus on the ESD firmware primarily.

Hmm, interesting thought.  I do have those earlier revisions (not sure from where though).  It would be cool if there was a revision log somewhere for David's fw.

I doubt he would share revision logs however he may actually help which version fits your current setup - https://www.dugasengineering.com/ +1 508 212 7236 (for some minor support fee I guess). But certainly you can try the earlier version before that.